Blog

python3.5安装lxml库

电脑安装py2.x和3.x不兼容,老是出问题,安装了2.x的包还得安装3.x的包,特别是最烦的lxml,弄了太久,写下博文,以免忘记

lxml官方文档: http://lxml.de/

pip install lxml 提示出错,改用easy_install lxml,还是出错

首先在cmd界面使用以下指令:

pip install wheel

其次打开http://www.lfd.uci.edu/~gohlke/pythonlibs/#lxml去下载lxml的Wheel文件,进入这个网站后用 ctrl+f 输入lxml回车即可找到
选择适合自己Python版本的whl文件,例如我的是win64位的,python3.5

下载到一个文件夹,记住路径,比如我下在d盘的Downloads中

然后打开cmd,进入你所下载的whl文件所在的文件夹,例如我是:输入D:进入D盘,然后cd Downloads进入放whl文件的文件夹

然后使用以下命令:

pip3 install lxml‑3.6.4‑cp35‑cp35m‑win_amd64.whl

注意,其中install后面的为字符所下载文件的名字以及后面还有.whl

然后就ok了

2 comments

  1. Jrady Jrady

    mark

    沙发
  2. Jrady Jrady

    mark

    板凳

Leave a Reply

你必须登入才能评论。